Seite 1 von 1

Fehler bei der Zuordnung einer Sollbuchung

Verfasst: Sonntag 24. Mai 2026, 12:22
von hyperfix
Ich habe eine Buchung angelegt über 10,50 €, dann eine Splitbuchung daraus gemacht und wollte drei Splitbuchungen über 3,50 € daraus erzeugen. Das funktioniert auch, allerdings will ich jede Buchung einem anderen Mitglied zuordnen, was ich im Buchungsdialog über "Sollbuchung - Sollbuchung erzeugen und Istbuchung zuordnen" vornehmen wollte. Dabei erhalte ich allerdings den Fehler "Fehler bei der Zuordnung der Sollbuchung".
Dann habe ich versucht, dies in der Übersicht der Buchungen über rechte Maustaste - Sollbuchung zuordnen vorzunehmen. Dort erscheint der selbe Fehler.

Re: Fehler bei der Zuordnung einer Sollbuchung

Verfasst: Sonntag 24. Mai 2026, 18:10
von joma
Ich habe das bei mir ausprobiert und da klappt es.
Kannst du uns das jameica.log File posten, um zu sehen wo es bei dir klemmt.

Re: Fehler bei der Zuordnung einer Sollbuchung

Verfasst: Montag 25. Mai 2026, 17:54
von hyperfix
Ich habe mal ins Log geschaut. Der Verwendungszweck ist anscheinend zu lang:
Caused by: org.h2.jdbc.JdbcSQLDataException: Wert zu gross / lang für Feld """ZWECK"" VARCHAR(140)":
Ich habe ihn jetzt gekürzt, sodass die Speicherung wieder möglich war. Eigentlich müssten die Felddimensionen aber gleich sein bei einer Splitbuchung / Sollbuchung, sodass in der Datenbank die Felder angepasst werden müssten?

Re: Fehler bei der Zuordnung einer Sollbuchung

Verfasst: Montag 25. Mai 2026, 18:02
von joma
In Buchungen darf der Verwendungszweck nur 140 Zeichen lang sein.
Wir müssen die Eingabe am GUI so machen, dass kein längerer Wert eingegeben werden kann.

Re: Fehler bei der Zuordnung einer Sollbuchung

Verfasst: Mittwoch 27. Mai 2026, 09:37
von joma
Ich habe jetzt doch die DB Länge bei den Sollbuchungpositionen auf 500 vergrößert. Damit kann man bei den Buchungen auch bei 500 bleiben.
Es kommt in die nächste neu Version 4.2.0.